亿操盘

亿操盘 首页 交易软件相关 查看内容

天财藏金-掌股专家系列特色公式源码大全-通达信适用 - 股票软件、指标公式、证券书籍 ...

2018-9-29 22:29| 发布者: yicaopan| 查看: 74| 评论: 0|原作者: [db:作者]|来自: [db:来源]

软件简介:

策略家数据中心版特色公式

博弈资金

aa:=VOL/CAPITAL*100;
A:=MA(aa,2);
主力:A,DRAW3D,COLORYELLOW;
B:=MA(aa,4);
游资:B,DRAW3D,RGB(255,0,128);
C1:=MA(aa,9);
私募:C1,DRAW3D,COLORGREEN;
D:=MA(aa,17);
大户:D,DRAW3D,COLORRED;
E:=MA(aa,34);
散户:E,DRAW3D,COLORCYAN ;
市场成本:MA(aa,180),0,COLORBLUE,2,2;


策略KD
n1   5
n2   5

VAR1:=C-REF(C,1);
VAR2:=O-REF(O,1);
VAR3:=H-REF(H,1);
VAR4:=L-REF(L,1);
var5:=(var1*7+var2+var3+var4)/10;
mtm:=var5*VOL;
ZLGJ:100*EMA(EMA(mtm,n1),n1)/EMA(EMA(ABS(mtm),n1),n1),0,COLORBLUE,0,2;
MAZL:MA(ZLGJ,N2),0,COLORMAGENTA,0,2;


策略MACD

short   12

long     26

m        9

a:=VOL*CLOSE;
b:=CLOSE;
b1:=EMA(b,17);
资金:=(b-b1)*100/b;
DIFF : EMA(资金,SHORT) - EMA(资金,LONG),0,RGB(0,255,0);
DEA  : EMA(DIFF,M),0,COLORCYAN ;
MACD : 2*(DIFF-DEA),COLORSTICK;
partline(diff>=REF(diff,1),diff),0,RGB(255,0,0);
金叉:STICKLINE(CROSS(ZLGJ,MAZL),ZLGJ,ZLGJ+10,-1,0),0,COLORRED,0,2;
死叉:STICKLINE(CROSS(MAZL,ZLGJ),ZLGJ,ZLGJ-10,-1,0),0,COLORGREEN,0,2;


FBZ

PBZ:=((H-O)+(C-L))/(2*(H-L))*100;
PBZ5:MA(PBZ,5),0,COLORRED,0,1;
PBZ10:MA(PBZ,10),0,COLORGREEN,0,1;
PBZ20:MA(PBZ,20),0,COLORYELLOW,0,1;
Z20:20;
Z50:50;
Z80:80;
Z100:20;
DRAWICON((CROSS(PBZ5,PBZ10) AND (PBZ10>REF(PBZ10,1)) AND REF(PBZ5,1)<50),50,2);

双向成交量


EV:=VOL;
实际V:EV/10000;
VAR1:=DYNAINFO(17)*REF(MA(VOL,5),1);
VAR2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
预测:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2)/10000;
{IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR3),COLORYELLOW;}
预测V:STICKLINE(IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2),VAR1,0,4,1),COLORGREEN;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE
买:买盘/10000,COLORYELLOW;
卖盘:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE
0-AA*(HIGH-LOW),0-VOL/2)),0,COLORGREEN;
卖:=卖盘/10000,COLORYELLOW;
换手:=VOL/CAPITAL*100,CIRCLEDOT,COLORYELLOW;
流通盘:=CAPITAL/1000000,POINTDOT;
流通市值:=(CAPITAL/100*C)/10000,1,RGB(51,204,255);
成交额2:=AMOUNT/10000000,POINTDOT;
虚拟成交量:STICKLINE(买盘>0,0,VOL,-1,1),1,COLORYELLOW;

{买盘5日均线:MA(买盘,5),0,RGB(0,255,255),1,1; }
买盘成交量:STICKLINE(买盘>0,0,买盘,-1,0),1,COLORRED;
卖盘成交量:STICKLINE(卖盘<0,0,卖盘,-1,0),1,COLORGREEN;


龙虎英雄榜公式


龙虎英雄

STICKLINE(C,C,0,-1,0),0,COLORBLUE;


机构持仓披露

{ 插入0101公式体开始 }

x1:=(BIGORDERP(1,3)-BIGORDERP(2,3))/(CLOSE*CAPITAL)*10000;
x2:=(BIGORDERP(1,0)-BIGORDERP(1,1)-(BIGORDERP(2,0)-BIGORDERP(2,1)))/(CLOSE*CAPITAL)*10000;
{x3:=BIGORDER(1,2)-BIGORDERP(1,3)-BIGORDERP(2,2)+BIGORDERP(2,3);}
xx:=BIGORDERP(1,0)+BIGORDERP(2,0);
V1:=jgcy(0,1),0,COLORBLUE,0,5;
a2:=V1+SUM(x1,0),0,COLORBLUE,0,2;
s2:=V1+SUM(x2,0),0,COLORBLUE,0,2;
机构定期:STICKLINE(V1>0,V1,0,8,0),0,COLORRED;
机构实时:IF(V1>0,V1,a2+REF(V1,BARSLAST(V1)+1)),0,COLORBROWN  ,0,2;
散户实时:IF(V1>0,V1,s2+REF(V1,BARSLAST(V1)+1)),0,RGB(38,145,38),0,2;
一季度:=DRAWTEXT(MONTH=3 and DAY=31,V1*0.9,V1),
0,COLORBLACK  ;
中报:=DRAWTEXT( MONTH=6 AND DAY=30,V1*0.9,V1),
0,COLORBLACK ;
三季度:=DRAWTEXT(MONTH=9 and DAY=30,V1*0.9,V1),
0,RGB(26,102,58),0,2;
年报:=DRAWTEXT(MONTH=12 and DAY=31,V1*0.9,V1),
0,COLORBLUE;

{ 插入0101公式体结束 }


机构分类持仓

x1:=BIGORDERP(1,3)-BIGORDERP(2,3);
x2:=(BIGORDERP(1,2)-BIGORDERP(1,3))-(BIGORDERP(2,2)-BIGORDERP(2,3));
x3:=(BIGORDERP(1,1)-BIGORDERP(1,2))-(BIGORDERP(2,1)-BIGORDERP(2,2));
x4:=(BIGORDERP(1,0)-BIGORDERP(1,1))-(BIGORDERP(2,0)-BIGORDERP(2,1));
机构单:=x1;
V1:=jgcy(0,0)*CLOSE;
a0:=SUM(机构单,0)+REF(V1,BARSLAST(V1)+1);
a1:=REF(jgcy(1,0),BARSLAST(jgcy(1,0)))*CLOSE;
a5:=REF(jgcy(5,0),BARSLAST(jgcy(5,0))+1)*CLOSE;
a4:=REF(jgcy(4,0),BARSLAST(jgcy(4,0))+1)*CLOSE;
a3:=REF(jgcy(3,0),BARSLAST(jgcy(3,0))+1)*CLOSE;
a2:=REF(jgcy(2,0),BARSLAST(jgcy(2,0))+1)*CLOSE;
机构:IF(V1>0,V1,a0),0,COLORBLUE ,0,2;
基金:IF(jgcy(1,0)>0,JGCY(1,0)*CLOSE,a1),0,COLORRED,0,2;
QFII:IF(JGCY(5,0)>0,JGCY(5,0)*CLOSE,a5),0,COLORMAGENTA ,0,2;
社保:IF(JGCY(4,0)>0,jgcy(4,0)*CLOSE,a4),0,COLORCYAN ,0,2;
保险:IF(JGCY(3,0)>0,jgcy(3,0)*CLOSE,a3),0,COLORBROWN ,0,2;
券商:IF(JGCY(2,0)>0,jgcy(2,0)*CLOSE,a2),0,RGB(125,35,125) ,0,2;

基金十大重仓股

{ 插入筹码基金公式体开始 }
x1:=(BIGORDERP(1,3)-BIGORDERP(2,3))/(CLOSE*CAPITAL)*10000;
x2:=(BIGORDERP(1,0)-BIGORDERP(1,1)-(BIGORDERP(2,0)-BIGORDERP(2,1)))/(CLOSE*CAPITAL)*10000;
{x3:=BIGORDER(1,2)-BIGORDERP(1,3)-BIGORDERP(2,2)+BIGORDERP(2,3);}
xx:=BIGORDERP(1,0)+BIGORDERP(2,0);
V1:=jgcy(0,1),0,COLORBLUE,0,5;
a2:=V1+SUM(x1,0),0,COLORBLUE,0,2;
s2:=V1+SUM(x2,0),0,COLORBLUE,0,2;
机构实时:IF(V1>0,V1,a2+REF(V1,BARSLAST(V1)+1)),0,COLORBROWN  ,0,2;
散户实时:IF(V1>0,V1,s2+REF(V1,BARSLAST(V1)+1)),0,RGB(38,145,38),0,2;


a1:=CMLDJJCC(2)*100,0,COLORCYAN ,0,3;
b1:=STICKLINE(a1>0,a1,0,8,0),0,COLORRED,0;
一季度:=DRAWTEXT(MONTH=3 and DAY=31,a1*0.9,a1),
0,COLORCYAN  ;
中报:=DRAWTEXT( MONTH=6 AND DAY=30,a1*0.9,a1),
0,COLORBLUE;
三季度:=DRAWTEXT(MONTH=9 and DAY=30,a1*0.9,a1),
0,RGB(125,35,125);
年报:=DRAWTEXT(MONTH=12 and DAY=31,a1*0.9,a1),
0,COLORBROWN   ;

{ 插入筹码基金公式体结束 }

天财藏金-爱国者-英雄榜贵宾版特色指标


LH  主图

STICKLINE(C,C,0,-1,0),0,COLORBLUE;


机构持仓披露


{ 插入0101公式体开始 }

x1:=(BIGORDERP(1,3)-BIGORDERP(2,3))/(CLOSE*CAPITAL)*10000;
x2:=(BIGORDERP(1,0)-BIGORDERP(1,1)-(BIGORDERP(2,0)-BIGORDERP(2,1)))/(CLOSE*CAPITAL)*10000;
{x3:=BIGORDER(1,2)-BIGORDERP(1,3)-BIGORDERP(2,2)+BIGORDERP(2,3);}
xx:=BIGORDERP(1,0)+BIGORDERP(2,0);
V1:=jgcy(0,1),0,COLORBLUE,0,5;
a2:=V1+SUM(x1,0),0,COLORBLUE,0,2;
s2:=V1+SUM(x2,0),0,COLORBLUE,0,2;
机构定期:STICKLINE(V1>0,V1,0,8,0),0,COLORRED;
机构实时:IF(V1>0,V1,a2+REF(V1,BARSLAST(V1)+1)),0,COLORBROWN  ,0,2;
散户实时:IF(V1>0,V1,s2+REF(V1,BARSLAST(V1)+1)),0,RGB(38,145,38),0,2;
一季度:=DRAWTEXT(MONTH=3 and DAY=31,V1*0.9,V1),
0,COLORBLACK  ;
中报:=DRAWTEXT( MONTH=6 AND DAY=30,V1*0.9,V1),
0,COLORBLACK ;
三季度:=DRAWTEXT(MONTH=9 and DAY=30,V1*0.9,V1),
0,RGB(26,102,58),0,2;
年报:=DRAWTEXT(MONTH=12 and DAY=31,V1*0.9,V1),
0,COLORBLUE;

{ 插入0101公式体结束 }


机构分类持仓

x1:=BIGORDERP(1,3)-BIGORDERP(2,3);
x2:=(BIGORDERP(1,2)-BIGORDERP(1,3))-(BIGORDERP(2,2)-BIGORDERP(2,3));
x3:=(BIGORDERP(1,1)-BIGORDERP(1,2))-(BIGORDERP(2,1)-BIGORDERP(2,2));
x4:=(BIGORDERP(1,0)-BIGORDERP(1,1))-(BIGORDERP(2,0)-BIGORDERP(2,1));
机构单:=x1;
V1:=jgcy(0,0)*CLOSE;
a0:=SUM(机构单,0)+REF(V1,BARSLAST(V1)+1);
a1:=REF(jgcy(1,0),BARSLAST(jgcy(1,0)))*CLOSE;
a5:=REF(jgcy(5,0),BARSLAST(jgcy(5,0))+1)*CLOSE;
a4:=REF(jgcy(4,0),BARSLAST(jgcy(4,0))+1)*CLOSE;
a3:=REF(jgcy(3,0),BARSLAST(jgcy(3,0))+1)*CLOSE;
a2:=REF(jgcy(2,0),BARSLAST(jgcy(2,0))+1)*CLOSE;
机构:IF(V1>0,V1,a0),0,COLORBLUE ,0,2;
基金:IF(jgcy(1,0)>0,JGCY(1,0)*CLOSE,a1),0,COLORRED,0,2;
QFII:IF(JGCY(5,0)>0,JGCY(5,0)*CLOSE,a5),0,COLORMAGENTA ,0,2;
社保:IF(JGCY(4,0)>0,jgcy(4,0)*CLOSE,a4),0,COLORCYAN ,0,2;
保险:IF(JGCY(3,0)>0,jgcy(3,0)*CLOSE,a3),0,COLORBROWN ,0,2;
券商:IF(JGCY(2,0)>0,jgcy(2,0)*CLOSE,a2),0,RGB(125,35,125) ,0,2;

基金十大重仓股


{ 插入筹码基金公式体开始 }
x1:=(BIGORDERP(1,3)-BIGORDERP(2,3))/(CLOSE*CAPITAL)*10000;
x2:=(BIGORDERP(1,0)-BIGORDERP(1,1)-(BIGORDERP(2,0)-BIGORDERP(2,1)))/(CLOSE*CAPITAL)*10000;
{x3:=BIGORDER(1,2)-BIGORDERP(1,3)-BIGORDERP(2,2)+BIGORDERP(2,3);}
xx:=BIGORDERP(1,0)+BIGORDERP(2,0);
V1:=jgcy(0,1),0,COLORBLUE,0,5;
a2:=V1+SUM(x1,0),0,COLORBLUE,0,2;
s2:=V1+SUM(x2,0),0,COLORBLUE,0,2;
机构实时:IF(V1>0,V1,a2+REF(V1,BARSLAST(V1)+1)),0,COLORBROWN  ,0,2;
散户实时:IF(V1>0,V1,s2+REF(V1,BARSLAST(V1)+1)),0,RGB(38,145,38),0,2;


a1:=CMLDJJCC(2)*100,0,COLORCYAN ,0,3;
b1:=STICKLINE(a1>0,a1,0,8,0),0,COLORRED,0;
一季度:=DRAWTEXT(MONTH=3 and DAY=31,a1*0.9,a1),
0,COLORCYAN  ;
中报:=DRAWTEXT( MONTH=6 AND DAY=30,a1*0.9,a1),
0,COLORBLUE;
三季度:=DRAWTEXT(MONTH=9 and DAY=30,a1*0.9,a1),
0,RGB(125,35,125);
年报:=DRAWTEXT(MONTH=12 and DAY=31,a1*0.9,a1),
0,COLORBROWN   ;

{ 插入筹码基金公式体结束 }

天财藏金-股行家二代趋势决策系统白金版

操盘行家  主图

VAR1:=EMA(CLOSE,10)-EMA(CLOSE,50);
VAR2:=EMA(VAR1,3);
VAR3:=VAR1 > VAR2 ;
VAR4:=VAR1

{x3:STICKLINE( VAR3 , LOW*0.95,0 , -1,0 ),1,RGB(235,175,50);
x4:STICKLINE( VAR4 , HIGH*1.1,99999, -1, 0),1,COLORBLUE;}
DRAWTEXT(CROSS(VAR1 ,VAR2 ),LOW*0.98,'B'),1,COLORRED;
DRAWTEXT(CROSS(VAR2 ,VAR1),HIGH*1.02,'S'),1,COLORGREEN;
FILLRGN(LOW*0.94,0,VAR3 ,RGB(235,175,50),0,0);
FILLRGN(HIGH*1.08,99999,VAR4 ,COLORBLUE,0,0);


大道至简

N:=20;
jj:=(HIGH+LOW+CLOSE)/3;
qj0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
qj1:=IF(CAPITAL=0,qj0*(jj-MIN(CLOSE,OPEN)),qj0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
qj2:=IF(CAPITAL=0,qj0*(MIN(OPEN,CLOSE)-LOW),qj0*IF(HIGH=LOW,1,(jj-MIN(CLOSE,OPEN))));
qj3:=IF(CAPITAL=0,qj0*(HIGH-MAX(OPEN,CLOSE)),qj0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
qj4:=IF(CAPITAL=0,qj0*(MAX(CLOSE,OPEN)-jj),qj0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-jj)));
DDX:=((qj1+qj2)-(qj3+qj4))/SUM(VOL,60)*1;
DX:=MA(ddx,5)*n;
DDX1:=SMA(DX,3,1)*10;

{只做红波段}
VAR1:EMA(CLOSE,13)-EMA(CLOSE,55);
VAR2:EMA(VAR1,3);
VAR3:=VAR1>VAR2;
VAR4:=VAR1

x1:STICKLINE(VAR3,VAR1,VAR2,-1,0),1,COLORRED;
x2:STICKLINE(VAR4,VAR1,VAR2,-1,0),1,COLORGREEN;

进:DRAWICON(CROSS(VAR1,VAR2),VAR1,0),0,COLORRED;
出:DRAWICON(CROSS(VAR2,VAR1),VAR2,1),0,COLORGREEN;

定海神针


DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
A2:=IF(CROSS(diff,dea) and diff > 0 and dea >0,0,1);
能量线:IF (A2,A1/10,A1/100);

Var1:=EMA(MA(IF(CLOSE>OPEN,(CLOSE-OPEN)*VOL,IF(CLOSE
Var2:=EMA(MA(IF(CLOSE>REF(CLOSE,1),(CLOSE-REF(CLOSE,1))*VOL,IF(CLOSE
Var3:=EMA(MA(IF(OPEN>REF(CLOSE,1),(OPEN-REF(CLOSE,1))*VOL,IF(OPEN
Var4:=EMA(MA(IF(CLOSEOPEN,(OPEN-CLOSE)*VOL,0)),10),1);
Var5:=EMA(MA(IF(CLOSEREF(CLOSE,1),(REF(CLOSE,1)-CLOSE)*VOL,0)),10),1);
Var6:=EMA(MA(IF(OPENREF(CLOSE,1),(REF(CLOSE,1)-OPEN)*VOL,0)),10),1);
DX:=(Var1+Var2+Var3)/3/100;
CX:=(Var4+Var5+Var6)/3/100;
B1:=BARSLAST(REF(CROSS(DX,CX),1));
买:IF (CROSS(DX,CX) AND 能量线 >0.5 and 能量线 < 2 and diff > REF(diff,1) AND B1 >5,0,-7);

{卖:IF(A1>2 ,-7,0);}
Sar1:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
Sar2:=SMA(SMA(Sar1,3,1),3,1);
Sar3:=EMA(Sar2,5);
Sar4:=3*Sar2-2*Sar3;
Sar5:=IF(Sar4 < REF(Sar4,1),1,0);

buyp:=REF(CLOSE,BARSLAST(REF(买=0,1)))*1.07;
buyk:=REF(CLOSE,BARSLAST(REF(买=0,1)))*0.9;

buyd:=BARSLAST(REF(买=0,1));

卖1:=IF( HIGH > buyp and  买=-7,1,0);{已获利}
卖2:=IF(Sar5 and  买=-7,1,0);{注意顶部}
卖3:=IF(buyd > 10 and  买=-7 ,1,0);{超出短线操作持股天数}
卖4:=IF(LOW < buyk and  买=-7,1,0);{听天由命吧~已亏损10%}

x11:=买=0;
x12:=卖1=1;
a11:=BARSLAST(买=0);{买成立到现在的周期数}
x13:=IF(卖1=1 Or 卖2=1 Or 卖3=1 Or 卖4=1,1,0);
a12:=COUNT(x13=1,a11);
s1:DRAWTEXT(卖1=1 and a12=2,1,'已获利'),0,COLORRED;
s2:DRAWTEXT(卖1=0 and 卖2=1 and a12=2,1,'注意顶部'),0,COLORRED;
s3:DRAWTEXT(卖1=0 and 卖2=0 and 卖3=1 and a12=2,1,'超出持股天数'),0,COLORRED;
s4:DRAWTEXT(卖1=0 and 卖2=0 and 卖3=0 and 卖4=1 and a12=2,1,'止损'),0,COLORGREEN;


多空行家


Var2:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
Var3:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
Var4:=SMA(Var3,13,8);
高抛: 90, POINTDOT;
低吸: 0, POINTDOT;
多方能量: SMA(Var4,13,8),0,COLORRED,0,4;
空方能量: SMA(Var2,21,8),0,COLORGREEN,0,4;
买进: IF(CROSS(多方能量,45),18,0-4);
卖出: IF(CROSS(45,多方能量),18,0-4);
强弱分界: 45, CIRCLEDOT;


动力行家

N   5
N1 10

MTM : CLOSE-REF(CLOSE,N);
MTMMA : MA(MTM,N1);


估值行家  主图

Var1:=LLV(LOW,144);

超低: 1.382*Var1;
低估: 1.809*Var1;
行业:2.213*Var1;
成长: 2.618*Var1;
垄断: 3.023*Var1;

行家力道

LC:=REF(CLOSE,1);
个股力道:(SMA(MAX(CLOSE-LC,0),N,1))/(SMA(ABS(CLOSE-LC),N,1))*100,0,RGB(0,255,0);
CC:="1A0001$CLOSE";

LC1:=REF(CC,1);
大势力道:(SMA(MAX(CC-LC1,0),N,1))/(SMA(ABS(CC-LC1),N,1))*100,0,RGB(255,0,255);
强弱度:=个股力道-大势力道;

FILLRGN(大势力道,个股力道,强弱度>=0,COLORRED,强弱度<0,COLORGREEN);
{x1:STICKLINE(强弱度>=0,指数强弱,品种强弱,-1,1),0,COLORRED;
x2:STICKLINE(强弱度<0,指数强弱,品种强弱,-1,1),0,COLORGREEN;}


MA(个股力道,8);
l20:20,0,RGB(255,0,255);
l50:50,0,RGB(00,255,255);
l80:80,0,RGB(0,255,0);
A:AMOUNT/VOL*10;

群体恐惧

LC:=REF(CLOSE,1);
LC1:=REF(CLOSE,1);
群体心理:((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC1)),5,1)) * 100),0,COLORRED,0,2;
R:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
A:=SMA(R,3,1);
B:=SMA(A,3,1);
CCC:=(((B / 2) + 40) * 1.1);
x1:SMA(CCC,3,1),0,COLORCYAN,1,1;
恐惧区间:STICKLINE(C,x1,100,8,1),1,COLORCYAN;
DRAWICON(CROSS(x1,群体心理),群体心理,1);

群体贪婪

aa:=REF(CLOSE,1);
bbb:=SMA(MAX(CLOSE-aa,0),5,1)/SMA(ABS(CLOSE-aa),5,1)*1000;
hhh:=bbb-LLV(bbb,10);
ss:=(MA(hhh,2)*3+hhh*13)/16;
抄底线:=IF(ss>13,MA(ss,2),ss);
{21,CIRCLEDOT;}

x轴:120,0,COLORWHITE,2,1;
var1:=IF(抄底线>50,150,抄底线+100);
VarA:=BARSCOUNT(CLOSE)*3.142/180;
群体扫描K线: SIN(VarA*8)*100+100,0,COLORRED,1,2 ;
群体扫描T线: COS(VarA*8)*100+100,0,COLORYELLOW,1,2;
x1:STICKLINE(CROSS(var1,121),121,var1,0.2,0),1,RGB(255,00,00);
x2:STICKLINE(CROSS(var1,121),121,var1,8,0),1 ,RGB(204,00,00);
x3:STICKLINE(CROSS(var1,121),121,var1,7,0),1 ,RGB(204,00,51);
x4:STICKLINE(CROSS(var1,121),121,var1,6,0),1 ,RGB(204,51,0);
x5:STICKLINE(CROSS(var1,121),121,var1,5,0),1 ,RGB(204,51,102);
x6:STICKLINE(CROSS(var1,121),121,var1,4,0),1 ,RGB(255,51,51);
x7:STICKLINE(CROSS(var1,121),121,var1,3,0),1 ,RGB(255,51,102);
x8:STICKLINE(CROSS(var1,121),121,var1,2,0),1 ,RGB(255,102,51);
x9:STICKLINE(CROSS(var1,121),121,var1,1,0),1 ,RGB(255,102,102);


熊熊烈焰

A:=(2*C+H+L)/4;
{zljx:=HHV(a,21),colorred,linethick2;   }
zcjx:LLV(a,21);
{tomorrow:(4*ref(zcjx,1)-(h+l))/2,colorwhite;}
{PARTLINE(zcjx,(zcjx=REF(zcjx,1)),RGB(255,0,255),(zcjx
var1:=zcjx=REF(zcjx,1);
var2:=(LOW

DRAWICON(var1 and var2,zcjx,6);


{
var1:="high#week";
var2:="l#week";
var3:"hl.weekh#month";
var4:"hl.weekl#month";
}
{
EMA(c,3),color00FFFF;
EMA(c,5),color00FFFF;
EMA(c,8),color00FFFF;
EMA(c,10),color00FFFF;
EMA(c,12),color00FFFF;
EMA(c,15),color00FFFF;


EMA(c,30),colorred;
EMA(c,35),colorred;
EMA(c,40),colorred;
EMA(c,45),colorred;
EMA(c,50),colorred;
EMA(c,60),colorred;
}


一览无遗  主图


市值V:=C*CAPITAL*100/100000000;
股本g:=FINANCE(1)/10000;
流通L:=FINANCE(7)/10000;
市盈率LYR:=C/FINANCE(33);
市净率sjl:=C/FINANCE(34);
日换手率rhs:=VOL/CAPITAL*100;
净资产jzc:=FINANCE(34);
净资收益率syl:=FINANCE(37);
最新收益zxsy:=FINANCE(33);
每股公积金gjj:=FINANCE(18);
每股未分配wfp:=FINANCE(31);
主营净利润率:=FINANCE(21)/FINANCE(20)*100;
股东权益比:=FINANCE(36);
jg:=BIGORDERP(1,3)-BIGORDERP(2,3);
zl:=BIGORDERP(1,2)-BIGORDERP(2,2);
jg5:=SUM(jg,5);
zl5:=SUM(zl,5);
市值:DRAWTEXTABS(10,13,'流通市值:'+市值V+' '+'亿'),0,RGB(200,200,0);
股本:DRAWTEXTABS(140,13,'股本:'+股本g+' '+'亿'),0,RGB(220,200,0);
流通:DRAWTEXTABS(230,13,'流通:'+流通L+' '+'亿'),0,RGB(230,200,0);
市净率:DRAWTEXTABS(320,13,'市净率:'+市净率sjl+' '),0,RGB(240,200,0);
日换手率:DRAWTEXTABS(10,50,'日换手率:'+日换手率rhs+' '),0,RGB(10,200,0);
净资产:DRAWTEXTABS(10,30,'净资产:'+净资产jzc+'元 '),0,RGB(200,00,200);
净资收益率:DRAWTEXTABS(230,30,'净资收益率:'+净资收益率syl+'% '),0,RGB(220,0,200);
最新收益:DRAWTEXTABS(110,30,'最新收益:'+最新收益zxsy+'元 '),0,RGB(210,0,200);
每股未分配:DRAWTEXTABS(110,50,'每股未分配:'+每股未分配wfp+'元 '),0,RGB(0,255,0);
每股公积金:DRAWTEXTABS(250,50,'每股公积金:'+每股公积金gjj+'元 '),0,RGB(0,255,0);
机构流入:DRAWTEXTABS(10,70,'机构流入:'+jg+'万元   占盘:'+IF(CAPITAL>0,jg*100*1000/(C*CAPITAL),0)+'‰'),0,RGB(255,255,0);
主力流入:DRAWTEXTABS(10,90,'主力流入:'+zl+'万元   占盘:'+IF(CAPITAL>0,zl*100*1000/(C*CAPITAL),0)+'‰'),0,RGB(255,255,0);
机构5日流入:DRAWTEXTABS(10,110,'机构5日流入:'+jg5+'万元   占盘:'+IF(CAPITAL>0,jg5*100*1000/(C*CAPITAL),0)+'‰'),0,RGB(255,255,0);
主力5日流入:DRAWTEXTABS(10,130,'主力5日流入:'+SUM(zl,5)+'万元   占盘:'+IF(CAPITAL>0,SUM(zl,5)*100*1000/(C*CAPITAL),0)+'‰'),0,RGB(255,255,0);

主力动能

主力资金:=SUM((BIGORDERP(1,2)-BIGORDERP(2,2)),5);

主力资金A:主力资金,0,RGB(255,125,0),0,1;
主力资金B:EMA(主力资金,5),0,RGB(0,0,255),0,1;


三十六计  基于恒富数据的持仓


ADCC-暗度陈仓

机构买:=BIGORDERP(1,3);
机构卖:=BIGORDERP(2,3);
大户买:=BIGORDERP(1,2)-BIGORDERP(1,3);
大户卖:=BIGORDERP(2,2)-BIGORDERP(2,3);
机构净值:=机构买-机构卖;
大户净值:=大户买-大户卖;
x轴:0,0,RGB(255,255,255),1,1;
机构净买:STICKLINE(机构净值>0,机构净值,0,-1,0),0,RGB(255,0,0);
机构净卖:STICKLINE(机构净值<0,机构净值,0,-1,0),0,RGB(0,128,64);
大户净买:STICKLINE(大户净值>0,大户净值+IF(机构净值>0,机构净值,0),IF(机构净值>0,机构净值,0),-1,0),0,RGB(253,168,53);
大户净卖:STICKLINE(大户净值<0,(大户净值+IF(机构净值>0,0,机构净值)),IF(机构净值>0,0,机构净值),-1,0),0,RGB(168,255,81);
主力持仓:SUM(机构净值+大户净值,0),0,RGB(0,0,255),1,2;


瞒天过海

EV:=VOL;
实际V:=EV/10000,0,COLORYELLOW,1,1;
VAR1:=DYNAINFO(17)*REF(MA(VOL,5),1);
VAR2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
预测:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2)/10000;
{IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR3),COLORYELLOW;}
预测V:=STICKLINE(IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2),VAR1,0,-1,1),1,COLORGREEN;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE
买:=买盘/10000,COLORYELLOW;
卖盘:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE
0-AA*(HIGH-LOW),0-VOL/2)),0,COLORGREEN;
卖:=卖盘/10000,COLORYELLOW;
换手:=VOL/CAPITAL*100,CIRCLEDOT,COLORYELLOW;
流通盘:=CAPITAL/1000000,POINTDOT;
流通市值:=(CAPITAL/100*C)/10000,1,RGB(51,204,255);
成交额2:=AMOUNT/10000000,POINTDOT;
虚拟成交量:STICKLINE(买盘>0,0,VOL,-1,1),1,COLORBLUE;

买盘5日均线:MA(买盘,5),0,RGB(255,0,255),1,1;
买V:STICKLINE(买盘>0,0,买盘,-1,0),1,COLORRED;
卖V:STICKLINE(卖盘<0,0,卖盘,-1,0),1,COLORGREEN;


以逸待劳


机构买:=BIGORDERP(1,3);
机构卖:=BIGORDERP(2,3);
大户买:=BIGORDERP(1,2)-BIGORDERP(1,3);
大户卖:=BIGORDERP(2,2)-BIGORDERP(2,3);
机构买入:STICKLINE(机构买,机构买,0,-1,0),0,RGB(255,0,0);
机构卖出:STICKLINE(机构卖,-机构卖,0,-1,0),0,RGB(0,128,64);
主力买入:STICKLINE(大户买,大户买+机构买,机构买,-1,0),0,RGB(253,168,53);
主力卖出:STICKLINE(大户卖,-(大户卖+机构卖),-机构卖,-1,0),0,RGB(168,255,81);
净差:机构买+大户买-(机构卖+大户卖),0,COLORWHITE,0,1;


资金动能

DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
DEA:=EMA(DIFF,5);
MACD := 2*(DIFF-DEA);
x1:=EMA(DIFF,5)*5;
x2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;
x3:IF(x2>0,x2,0),DRAW3D,COLORRED;
x4:IF(x2<0,x2,0),DRAW3D,COLORGREEN;
资金动能A:x2,0,RGB(255,128,0),0,2;
资金动能B:x1,0,RGB(0,0,255),0,2;
AA:DRAWICON((CROSS(资金动能A,资金动能B) and 资金动能B<-0.25),资金动能B,0),0,RGB(0,255,255),0,2;


3.恒富数据

DHD-大户单

t1:=BIGORDERP(1,2)-BIGORDERP(1,3);
t2:=BIGORDERP(2,2)-BIGORDERP(2,3);
t3:=(t1-t2);
净买:STICKLINE(t3>0,t3,0,-1,0),0,RGB(255,0,0);
净卖:STICKLINE(t3<0,t3,0,-1,0),0,RGB(0,255,0);

JGD-机构单

t1:=BIGORDERP(1,3);
t2:=BIGORDERP(2,3);
t3:=(t1-t2);
//f100:(-100),0,RGB(255,255,0),2,1;
净买:STICKLINE(t3>0,t3,0,-1,0),0,RGB(255,0,0);
净卖:STICKLINE(t3<0,t3,0,-1,0),0,RGB(0,255,0);


SHD-散户单

t1:=BIGORDERP(1,0)-BIGORDERP(1,1);
t2:=BIGORDERP(2,0)-BIGORDERP(2,1);
t3:=(t1-t2);
净买:STICKLINE(t3>0,t3,0,-1,0),0,RGB(255,0,0);
净卖:STICKLINE(t3<0,t3,0,-1,0),0,RGB(0,255,0);

ZHD-中户单

t1:=BIGORDERP(1,1)-BIGORDERP(1,2);
t2:=BIGORDERP(2,1)-BIGORDERP(2,2);
t3:=(t1-t2);
净买:STICKLINE(t3>0,t3,0,-1,0),0,RGB(255,0,0);
净卖:STICKLINE(t3<0,t3,0,-1,0),0,RGB(0,255,0);


ZLCB-主力成本

zlb:=BIGORDERP(1,2);
zls:=BIGORDERP(2,2);
zlbv:=BIGORDEREXT(9)+BIGORDEREXT(8);
zlsv:=BIGORDEREXT(13)+BIGORDEREXT(12);
买:zlb*100/zlbv;
买5:IF (REF(zlbv,4)<>0,SUM(zlb*100,5)/SUM(zlbv,5),买);
买10:IF (REF(zlbv,9)<>0,SUM(zlb*100,10)/SUM(zlbv,10),买);
买30:IF (REF(zlbv,29)<>0,SUM(zlb*100,30)/SUM(zlbv,30),买);
卖:=zls*100/zlsv;
最新价:=C;
{DRAWICON(CROSS(买5,买10),买,0);}


ZLCB-主力成本卖


zlb:=BIGORDERP(1,2);
zls:=BIGORDERP(2,2);
zlbv:=BIGORDEREXT(9)+BIGORDEREXT(8);
zlsv:=BIGORDEREXT(13)+BIGORDEREXT(12);
买:=zlb*100/zlbv;
买5:=IF (REF(zlbv,4)<>0,SUM(zlb*100,5)/SUM(zlbv,5),买);
买10:=IF (REF(zlbv,9)<>0,SUM(zlb*100,10)/SUM(zlbv,10),买);
买30:=IF (REF(zlbv,29)<>0,SUM(zlb*100,30)/SUM(zlbv,30),买);
卖:zls*100/zlsv;
卖5:IF (REF(zlsv,4)<>0,SUM(zls*100,5)/SUM(zlsv,5),卖);
卖10:IF (REF(zlsv,9)<>0,SUM(zls*100,10)/SUM(zlsv,10),卖);
卖30:IF (REF(zlsv,29)<>0,SUM(zls*100,30)/SUM(zlsv,30),卖);

ZLHL-主力获利


zlb:=(BIGORDERP(1,2));
zls:=(BIGORDERP(2,2));
zlbv:=BIGORDEREXT(9)+BIGORDEREXT(8);
zlsv:=BIGORDEREXT(13)+BIGORDEREXT(12);
主力成本买:=zlb*100/zlbv;
主力成本卖:=zls*100/zlsv;
主力成本买30:IF (REF(zlbv,29)<>0,SUM(zlb*100,30)/SUM(zlbv,30),主力成本买);
买30:=主力成本买30;
最新价:=CLOSE;
FILLRGN(买30,最新价,买30<最新价,RGB(235,175,50),买30>=最新价,RGB(5,0,205));


ZLHL-主力卖获利

zlb:=(BIGORDERP(1,2));
zls:=(BIGORDERP(2,2));
zlbv:=BIGORDEREXT(9)+BIGORDEREXT(8);
zlsv:=BIGORDEREXT(13)+BIGORDEREXT(12);
主力成本买:=zlb*100/zlbv;
主力成本卖:=zls*100/zlsv;
主力成本买30:=IF (REF(zlbv,29)<>0,SUM(zlb*100,30)/SUM(zlbv,30),主力成本买);
主力成本卖30:IF (REF(zlsv,29)<>0,SUM(zls*100,30)/SUM(zlsv,30),主力成本卖);
卖30:=主力成本卖30;
最新价:=CLOSE;
FILLRGN(卖30,最新价,卖30<最新价,RGB(235,175,50),卖30>=最新价,RGB(5,0,205));


4.跟风盘指标

跟风盘大户净买

主买:=BIGORDER(1,2)-BIGORDER(1,3);
主卖:=BIGORDER(2,2)-BIGORDER(2,3);
result:=(主买-主卖)/10000;
x1:IF(result>0,result,0),DRAW3D,COLORRED;
x2:IF(result<0,result,0),DRAW3D,COLORGREEN;
三日平均:MA(result,3);


跟风盘特大户净买

主买:=BIGORDER(1,3);
主卖:=BIGORDER(2,3);
result:=(主买-主卖)/10000;
x1:IF(result>0,result,0),DRAW3D,COLORRED;
x2:IF(result<0,result,0),DRAW3D,COLORGREEN;
三日平均:MA(result,3);


跟风盘小户净买


主买:=BIGORDER(1,0)-BIGORDER(1,1);
主卖:=BIGORDER(2,0)-BIGORDER(2,1);
result:=(主买-主卖)/10000;
x1:IF(result>0,result,0),DRAW3D,COLORRED;
x2:IF(result<0,result,0),DRAW3D,COLORGREEN;
三日平均:MA(result,3);

跟风盘中户净买


主买:=BIGORDER(1,1)-BIGORDER(1,2);
主卖:=BIGORDER(2,1)-BIGORDER(2,2);
result:=(主买-主卖)/10000;
x1:IF(result>0,result,0),DRAW3D,COLORRED;
x2:IF(result<0,result,0),DRAW3D,COLORGREEN;
三日平均:MA(result,3);


跟庄到底主图


短期生命线:EMA(CLOSE,4);
中期生命线:EMA(CLOSE,18);
长期生命线:EMA(CLOSE,55);


6.行家排行
恒富连红排序

时间区间    20

a1:=BIGORDERP(1,3)-BIGORDERP(2,3);
a2:=(BIGORDERP(1,2)-BIGORDERP(1,3))-(BIGORDERP(2,2)-BIGORDERP(2,3));
a3:=(BIGORDERP(1,1)-BIGORDERP(1,2))-(BIGORDERP(2,1)-BIGORDERP(2,2));
a4:=(BIGORDERP(1,0)-BIGORDERP(1,1))-(BIGORDERP(2,0)-BIGORDERP(2,1));
机构连红:LAST(a1>0);
机构5日内红:COUNT(a1>0,5);
机构10日内红:COUNT(a1>0,10);
机构N日内红:COUNT(a1>0,时间区间);
大户连红:LAST(a2>0);
大户5日内红:COUNT(a2>0,5);
大户10日内红:COUNT(a2>0,10);
大户N日内红:COUNT(a2>0,时间区间);
中户连绿:LAST(a3<0);
中户5日内绿:COUNT(a3<0,5);
中户10日内绿:COUNT(a3<0,10);
中户N日内绿:COUNT(a3<0,时间区间);
散户连绿:LAST(a4<0);
散户5日内绿:COUNT(a4<0,5);
散户10日内绿:COUNT(a4<0,10);
散户N日内绿:COUNT(a4<0,时间区间);

厚积薄发排序

时间区间    10
恒富分类    1
翻红日数    6
涨跌幅度    10

a1:=(BIGORDERP(1,3)-BIGORDERP(2,3))*10000;
a2:=((BIGORDERP(1,2)-BIGORDERP(1,3))-(BIGORDERP(2,2)-BIGORDERP(2,3)))*10000;
a3:=(a1+a2);

kk1:=IF(恒富分类=1,a1,0);
kk2:=IF(恒富分类=2,a2,0);
kk3:=IF(恒富分类=3,a3,0);
zl:=kk1+kk2+kk3;
量比‰:SUM(zl,时间区间)/SUM(AMOUNT,时间区间);
机构N日:SUM(a1,时间区间);
大户N日:SUM(a2,时间区间);
主力N日:SUM(a3,时间区间);
机构1日:a1;
大户1日:a2;
主力1日:a3;
机构5日:SUM(a1,5);
大户5日:SUM(a2,5);
主力5日:SUM(a3,5);
机构10日:SUM(a1,10);
大户10日:SUM(a2,10);
主力10日:SUM(a3,10);
COUNT(ZL>0,时间区间)>=翻红日数 AND (C/REF(C,时间区间)) <(1+涨跌幅度/100) and SUM(ZL,时间区间)〉0


逆势增仓排序

时间区间    3

zlb:=BIGORDERP(1,2);
zls:=BIGORDERP(2,2);
zl:=zlb- zls;
a1:=(BIGORDERP(1,3)-BIGORDERP(2,3))*10000;
a2:=((BIGORDERP(1,2)-BIGORDERP(1,3))-(BIGORDERP(2,2)-BIGORDERP(2,3)))*10000;
a3:=(a1+a2);
主力量比‰:SUM(a3,时间区间)/SUM(AMOUNT,时间区间);
机构N日:SUM(a1,时间区间);
大户N日:SUM(a2,时间区间);
主力N日:SUM(a3,时间区间);
机构1日:a1;
大户1日:a2;
主力1日:a3;
机构5日:SUM(a1,5);
大户5日:SUM(a2,5);
主力5日:SUM(a3,5);
机构10日:SUM(a1,10);
大户10日:SUM(a2,10);
主力10日:SUM(a3,10);
主力N日 > 0  AND C/REF(C,时间区间)<1

XA.特色指标

DKX  多空线

m   10

a:=(3*C+L+O+H)/6;

b:(20*a+19*REF(a,1)+18*REF(a,2)+17*REF(a,3)+16*REF(a,4)+15*REF(a,5)+14*REF(a,6)
+13*REF(a,7)+12*REF(a,8)+11*REF(a,9)+10*REF(a,10)+9*REF(a,11)+8*REF(a,12)
+7*REF(a,13)+6*REF(a,14)+5*REF(a,15)+4*REF(a,16)+3*REF(a,17)+2*REF(a,18)+
REF(a,20))/210;
d:MA(b,m)


QHLSR  阻力指标

qhl:=(C-REF(C,1))-(VOL-REF(VOL,1))*(REF(H,1)-REF(L,1))/REF(VOL,1);
a:=SUM(IF(qhl>0,qhl,0),5);
e:=SUM(IF(qhl>0,qhl,0),10);
b:=ABS(SUM(IF(qhl<0,qhl,0),5));
f:=ABS(SUM(IF(qhl<0,qhl,0),10));
d:=a/(a+b);
g:=e/(e+f);
qhl5: IF(SUM(IF(qhl>0,1,0),5)=5,1,IF(SUM(IF(qhl<0,1,0),5)=5,0,d)) ;
qhl10:g


条件选股


趋势机会提示


DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
A2:=IF(CROSS(diff,dea) and diff > 0 and dea >0,0,1);
能量线:=IF (A2,A1/10,A1/100);

Var1:=EMA(MA(IF(CLOSE>OPEN,(CLOSE-OPEN)*VOL,IF(CLOSE
Var2:=EMA(MA(IF(CLOSE>REF(CLOSE,1),(CLOSE-REF(CLOSE,1))*VOL,IF(CLOSE
Var3:=EMA(MA(IF(OPEN>REF(CLOSE,1),(OPEN-REF(CLOSE,1))*VOL,IF(OPEN
Var4:=EMA(MA(IF(CLOSEOPEN,(OPEN-CLOSE)*VOL,0)),10),1);
Var5:=EMA(MA(IF(CLOSEREF(CLOSE,1),(REF(CLOSE,1)-CLOSE)*VOL,0)),10),1);
Var6:=EMA(MA(IF(OPENREF(CLOSE,1),(REF(CLOSE,1)-OPEN)*VOL,0)),10),1);
DX:=(Var1+Var2+Var3)/3/100;
CX:=(Var4+Var5+Var6)/3/100;
买:=IF (CROSS(DX,CX) AND 能量线 >0.5 and 能量线 < 2 and diff > REF(diff,1),0,-7);
买=0;


趋势风险提示

DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
DEA:=EMA(DIFF,5);
MACD := 2*(DIFF-DEA);
x1:=EMA(DIFF,5)*5;
x2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*5;
x3:=IF(x2>0,x2,0),DRAW3D,COLORRED;
x4:=IF(x2<0,x2,0),DRAW3D,COLORGREEN;
资金动能A:=x2,0,RGB(255,128,0),0,2;
资金动能B:=x1,0,RGB(0,0,255),0,2;
卖:=IF((CROSS(资金动能B,资金动能A) and 资金动能B》0.25),资金动能B,0);
卖=资金动能B
 

  • 下载地址1

  • 鲜花

    握手

    雷人

    路过

    鸡蛋

    亿操盘  

    Copyright © 2001-2018 91yicaopan.   All Rights Reserved.

    Powered by 亿操盘 ( 辽ICP备15002194号-1 ) 联系电话: 4001825055

    返回顶部

    点击这里给我发消息

    客户服务热线

    400-182-5055

    在线客服