亿操盘

找回密码
立即注册
亿操盘 首页 交易软件相关 查看内容

公式改为选股公式的简易方法 - 股票软件、指标公式、证券书籍、炒股软件、股票分析软 ...

2018-9-29 22:29| 发布者: yicaopan| 查看: 56| 评论: 0|原作者: [db:作者]|来自: [db:来源]

软件简介:

指标改为选股指标的简易方法
 

以下是将公式改为选股公式的简易方法,求人不如求己嘛

步骤一.将所有的显示式":",改为不显示式":="
选股条件的基本要求为只能输出1个条件式,故要先将公式中所有的显示式":"改为不显示式":=",
如果原来显示式后面接有线型描述(颜色.对齐..),也一并删除

例如:
ma1:ma(c,5),colorred;
ma2:ma(c,10),colorgreen,POINTDOT;
.....

先改为

ma1:=ma(c,5);
ma2:=ma(c,10);
.....

步骤二.找出选股条件,并写成选股式引用:
条件的寻找方法,依不同目的,大致可分以下几种:
--------------------------------------------------------------------------------------------
1.''选股     :''选股
方法:先找出公式中出现有''的地方,该式开头会以DRAW..TEXT开头,
DRAWTEXT  DRAWTEXTEX  DRAWYITEXT DRAWFLAGTEXT DRAWMOVETEXT
找到后,该函数(条件, ,'')后面括号内的第1个即为条件,将该条件复制出来并加上分号即可

例如:
{
'5日均>10日均'选股
}
ma1:=ma(c,5);
ma2:=ma(c,10);
DRAWTEXT(ma1>ma2,ma1,'5
日均>10日均
');
[
]
ma1:=ma(c,5);
ma2:=ma(c,10);
ma1>ma2;
--------------------------------------------------------------------------
2.图标选股     :笑脸选股
方法:
先依不同软件,找出该图标的代号
,
再找出公式中出现DRAWICON函数(条件,   ,图标代号)的式子,对照图标的代号(括号内的第3),如果该图标代号为所求代号
,
该函数后面括号内的第1个即为条件,将该条件复制出来并加上分号即可

例如:
{
求图标1选股
}
ma1:=ma(c,5);
ma2:=ma(c,10);
DRAWicon(ma1>ma2,ma1,1);
[
]
ma1:=ma(c,5);
ma2:=ma(c,10);
ma1>ma2;
--------------------------------------------------------------------------------
3.A线上穿(下穿)B线选股  {上穿--金叉,下穿--死叉}
方法:A线上穿B线:  cross(A,B);
     A
线下穿B线
:  cross(B,A);
例如
:
{
ma1上穿ma2选股
}
ma1:ma(c,5);
ma2:ma(c,10);
[
]
ma1:=ma(c,5);
ma2:=ma(c,10);
cross(ma1,ma2);

{
ma1下穿ma2选股
}
ma1:ma(c,5);
ma2:ma(c,10);
[
]
ma1:=ma(c,5);
ma2:=ma(c,10);
cross(ma2,ma1);

-------------------------------------------------------------------------------------------
4.线A上穿(下穿) 选股  
方法:线A上穿:  cross(A,ma(A,2));      cross(A,ref(A,1));
     
线A下穿:  cross(ma(A,2),A);   
  cross(ref(A,1),A);
例如
:
{
求改成ma1上穿
}
ma1:ma(c,5);
[
]
ma1:=ma(c,5);
cross(ma1,ma(ma1,2));

ma1:=ma(c,5);
cross(ma1,ref(ma1,1));

{
求改成ma1下穿}
ma1:ma(c,5);
[
]
ma1:=ma(c,5);
cross(ma(ma1,2),ma1);
  
ma1:=ma(c,5);
cross(ref(ma1,1),ma1);
---------------------------------------------------------------------------------------------
5.1次出现条件A 选股
方法:先找出条件A,
     
再利用
cross(A,0.5);

例如
:
{
求改成出现图标1选股
}
ma1:=ma(c,5);
ma2:=ma(c,10);
DRAWicon(ma1>ma2,ma1,1);
[
1]
ma1:=ma(c,5);
ma2:=ma(c,10);
A:=ma1>ma2;
cross(A,0.5);
[
2--直接将条件A写入
]
ma1:=ma(c,5);
ma2:=ma(c,10);
cross(ma1>ma2,0.5);
-------------------------------------------------------------------------------------------
6.线变色选股   :黄线变红色选股 (指标线为黄线,再利用函数变红色线)
方法:先依不同软件,找出条件A,
     
再用
cross(A,0.5);

(1)飞狐
条件在PARTLINE(条件A, ),colorred;括号内的第1个即为条件,将该条件复制出来并加上分号即可
例如:
{
求黄线变红色选股  飞狐
}
ma1:ma(c,5),coloryellow;
PARTLINE(ma1>REF(ma1,1),ma1),colorred;
[
]
ma1:=ma(c,5);
A:=ma1>REF(ma1,1);
cross(A,0.5);

(
2)大智慧L2.分析家
条件在PARTLINE(  ,条件A,rgb(255,0,0),  , ...);
括号内为rgb(255,0,0)的前1个即为条件,将该条件复制出来并加上分号即可

例如:
{
求黄线变红色选股  大智慧L2.分析家
}
ma1:=ma(c,5);
PARTLINE(ma1,ma1>REF(ma1,1),rgb(255,0,0),1,rgb(255,255,0));
[
]
ma1:=ma(c,5);
A:=ma1>REF(ma1,1);
cross(A,0.5);

(3)通达信
条件在IF(条件A,   ,DRAWNULL),colorred;括号内的第1个即为条件,将该条件复制出来并加上分号即可
例如:
{
求黄线变红色选股  通达信
}
MA1:MA(C,5),COLORYELLOW;
IF(MA1>REF(MA1,1),MA1,DRAWNULL),COLORRED;
[
]
MA1:=MA(C,5);
A:=MA1>REF(MA1,1);
CROSS(MA1>REF(MA1,1),0.5);
--------------------------------------------------------------------------------
7.颜色柱选股
方法:先找出公式中出现有STICKLINE函数的地方,
找到后,核对该函数后面的颜色,是否为所求颜色
,
若颜色相同,则括号内的第1个即为条件A,将该条件复制出来并加上分号即可


例如:
{
求红色柱选股
}
STICKLINE(
c>o,h,l,0.8,1),colorred;
[
]
A:c>o;

{
求第1次红色柱选股
}
STICKLINE(c>o,h,l,0.8,1),colorred;
[
]
A:=c>o;
cross(A,0.5);

步骤三.最后将所有绘图函数及单一输出值( 0;  k;  if(,,); )全删除,使公式只剩1个选股式输出即成,
(
若有2个以上条件,条件同时成立时,可在条件间用"and"连接;
  
若有2个以上条件,允许条件不同时成立时,可在条件间用"or"连接)

 

  • 本地高速下载

  • 鲜花

    握手

    雷人

    路过

    鸡蛋

    亿操盘  

    Copyright © 2001-2018 91yicaopan.   All Rights Reserved.

    Powered by 亿操盘 ( 辽ICP备15002194号-1 )

    返回顶部