亿操盘

找回密码
立即注册
亿操盘 首页 交易软件相关 查看内容

博易 海龟通道和波动率的组合(源码 贴图 用法) - 股票软件、指标公式、证券书籍、炒 ...

2018-9-29 22:29| 发布者: yicaopan| 查看: 67| 评论: 0|原作者: [db:作者]|来自: [db:来源]

软件简介:

箭头是海龟通道信号 20日
变色k线是波动率突破10日平均波动的1.5倍
两个信号在1-5日内同时出现,就可以开仓。
欢迎大家来优化

UPQK:=LOW-REF(HIGH,1);
STICKLINE(CLOSE>REF(CLOSE,1) AND UPQK>0,REF(HIGH,1),LOW,15,1),COLORYELLOW;
DOWNQK:=REF(LOW,1)-HIGH;
STICKLINE(CLOSE<REF(CLOSE,1) AND DOWNQK>0,REF(LOW,1),HIGH,15,1),COLORGREEN;

MA10:MA(CLOSE,170),COLOR0000FF;
MA20:MA(CLOSE,350),COLORFF0080;
DRAWKLINE(H,O,L,C);
N:=20;T:=20;
M1:=MA(C,N);
HPB:=REF(HHV(H,N),1);
LPB:=REF(LLV(L,T),1);
{多头交易}
BUYIN:=H>HPB ;
BUYEXIT:=L<LPB;
SINGAL:=IF(BUYIN,1,IF(BUYEXIT,-1,0));
CURRSIGN:=REF(SINGAL,BARSLAST(SINGAL));
UPTREND:=CURRSIGN= 1;
DWTREND:=CURRSIGN=-1;
{跟踪止损}
空平:=IF(DWTREND,HPB,M1),LINETHICK2; 
多止:=IF(UPTREND,LPB,M1),LINETHICK2;
信号持续:=IF(DWTREND,BARSLAST(UPTREND),BARSLAST(DWTREND)),LINETHICK0;
DRAWICON(BARSLAST(DWTREND)=1,多止,4);
DRAWICON(BARSLAST(UPTREND)=1,空平,5);

{DRAWGBKLAST(CLOSE>0,STRIP(RGB(95,95,95),RGB(0,0,0),0))}
VAR1:=AMOUNT/VOL/100;
指导: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA
  (CLOSE,24))/4,2),COLORWHITE;
界: MA(CLOSE,27),COLORYELLOW;
红轨道:MA(MA(CLOSE,3),1),LINETHICK1,COLOR0000FF;
绿轨道:MA(MA(CLOSE,3),3),LINETHICK1,COLOR00FF00;

{波动}
TR := MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR := MA(TR,10);
STICKLINE((TR>ATR*1.5) AND (C <O),O,C,4,0),COLOR00FF00;
STICKLINE((TR>ATR*1.5) AND (C >O),O,C,4,0),COLORMAGENTA;
  • 下载地址1

  • 鲜花

    握手

    雷人

    路过

    鸡蛋

    亿操盘  

    Copyright © 2001-2018 91yicaopan.   All Rights Reserved.

    Powered by 亿操盘 ( 辽ICP备15002194号-1 )

    返回顶部