亿操盘

找回密码
立即注册
亿操盘 首页 通达信公式 查看内容

支撑与压力 - 股票软件、指标公式、证券书籍、炒股软件、股票分析软件下载 -亿操盘 ...

2018-9-29 21:50| 发布者: yicaopan| 查看: 60| 评论: 0|原作者: [db:作者]|来自: [db:来源]

软件简介:

支撑与压力

{TS:350 N:95填写在公式编辑器上面空格里}
DA1:=IF(TS>TOTALBARSCOUNT,TOTALBARSCOUNT,TS);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);{最高价}
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/15); {对数格值}
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(HI/POW(GZ,9)) AND C1<LO*POW(GZ,7),V,0),DA);
LH10:=SUM(IF(C1>=(LO*POW(GZ,5)) AND C1<LO*POW(GZ,6),V,0),DA);
LH11:=SUM(IF(C1>=(LO*POW(GZ,4)) AND C1<LO*POW(GZ,5),V,0),DA);
LH12:=SUM(IF(C1>=(LO*POW(GZ,3)) AND C1<LO*POW(GZ,4),V,0),DA);
LH13:=SUM(IF(C1>=(LO*POW(GZ,2)) AND C1<LO*POW(GZ,3),V,0),DA);
LH14:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH15:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE);
L2:=REFDATE(HHV(LH2,DA),DATE);
L3:=REFDATE(HHV(LH3,DA),DATE);
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
L11:=REFDATE(HHV(LH11,DA),DATE);
L12:=REFDATE(HHV(LH12,DA),DATE);
L13:=REFDATE(HHV(LH13,DA),DATE);
L14:=REFDATE(HHV(LH14,DA),DATE);
L15:=REFDATE(HHV(LH15,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10+L11+L12+L13+L14+L15);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT ,HI*N/100,HI/GZ,5,0)COLORGRAY;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT ,HI/POW(GZ,1)*N/100,HI/POW(GZ,2),5,0)COLORGRAY;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT ,HI/POW(GZ,2)*N/100,HI/POW(GZ,3),5,0)COLORGRAY;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT ,HI/POW(GZ,3)*N/100,HI/POW(GZ,4),5,0)COLORGRAY;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT ,HI/POW(GZ,4)*N/100,HI/POW(GZ,5),5,0)COLORGRAY;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT ,HI/POW(GZ,5)*N/100,HI/POW(GZ,6),5,0)COLORGRAY;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT ,HI/POW(GZ,6)*N/100,HI/POW(GZ,7),5,0)COLORGRAY;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT ,LO*POW(GZ,7),LO*POW(GZ,8)*N/100,5,0)COLORGRAY;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT ,LO*POW(GZ,6),LO*POW(GZ,7)*N/100,5,0)COLORGRAY;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT ,LO*POW(GZ,5),LO*POW(GZ,6)*N/100,5,0)COLORGRAY;
STICKLINE(CEILING(DA*L11/SS)*3>=CURRBARSCOUNT ,LO*POW(GZ,4),LO*POW(GZ,5)*N/100,5,0)COLORGRAY;
STICKLINE(CEILING(DA*L12/SS)*3>=CURRBARSCOUNT ,LO*POW(GZ,3),LO*POW(GZ,4)*N/100,5,0)COLORGRAY;
STICKLINE(CEILING(DA*L13/SS)*3>=CURRBARSCOUNT ,LO*POW(GZ,2),LO*POW(GZ,3)*N/100,5,0)COLORGRAY;
STICKLINE(CEILING(DA*L14/SS)*3>=CURRBARSCOUNT ,LO*POW(GZ,1),LO*POW(GZ,2)*N/100,5,0)COLORGRAY;
STICKLINE(CEILING(DA*L15/SS)*3>=CURRBARSCOUNT ,LO,LO*POW(GZ,1)*N/100,5,0),COLORGRAY;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
五:MA(C,5);
  • 本地高速下载
  • 下载地址2

  • 鲜花

    握手

    雷人

    路过

    鸡蛋

    亿操盘  

    Copyright © 2001-2018 91yicaopan.   All Rights Reserved.

    Powered by 亿操盘 ( 辽ICP备15002194号-1 )

    返回顶部