亿操盘

找回密码
立即注册
亿操盘 首页 大智慧公式 查看内容

DDE决策 - -上证50ETF期权

2018-12-6 06:00| 发布者: yicaopan| 查看: 15| 评论: 0|原作者: [db:作者]|来自: [db:来源]

软件简介:

 {输出}

MA157:eMA(CLOSE,157),colorFF7676;
MA5:eMA(CLOSE,5),COLORFFAA66;
MA11:eMA(CLOSE,11),COLORFFFFCC;
MA24:eMA(CLOSE,24),Color9DFFFF;
MA38:eMA(CLOSE,38),ColorABFF46;
MA55:eMA(CLOSE,55),Color8000FF;
MA96:MA(CLOSE,96),POINTDOT,linethick4,colorYellow;
MA191:eMA(CLOSE,191),Colorffffff;
MA262:eMA(CLOSE,262),colorfaabec;
MA314:eMA(CLOSE,314),color00ff00;
MA453:eMA(CLOSE,453),colorCyan;
 
DRAWGBK(c,'7' );
Var3:=LLV(H,240);
Var4:=100*(C-Var3)/Var3;
Var5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;
Var6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;
Var7:=0;
Var8:=MA(HHV(C-REF(C,1),0),34)/MA(ABS(C-REF(C,1)),7)*100;
Var9:=MA(HHV(C-REF(C,1),0),13)/MA(ABS(C-REF(C,1)),13)*100;
VarA:=BARSCOUNT(C);
VarB:=Var8<20 AND Var9<23 AND VarA>35;
VarC:=VarB AND COUNT(VarB,1)=1;
VarD:=EMA(C,21)-EMA(C,8);
VarE:=EMA(VarD,5);
VarF:=TROUGH(3,6,1)<4 AND CROSS(VarD,VarE);
Var10:=IF(TROUGH(3,16,1)=0 AND H>L+0.04,4,0);
Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
Var12:=ZIG(3,6)<REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
Var13:=ZIG(3,22)>REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
Var14:=ZIG(3,22)<REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
Var15:=ZIG(3,51)>REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
Var16:=ZIG(3,51)<REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
Var18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
Var19:=EMA(C,2)-EMA(C,150);
Var1A:=EMA(Var19,100);
Var1B:=2*(Var19-Var1A);
Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);
Var1D:=SQRT(SQRT(L*H*O*C));
Var1E:=EMA(Var1D*0.97,3);
Var1F:=(H+L+C)/3;
Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));
Var21:=CROSS(Var1E,L);
买点1:=Var10;
买点2:=(Var11+Var13+Var15+Var17);
卖点1:=(Var12+Var14+Var16+Var18);
Var22:=买点1 AND VarF AND VarC AND Var21 AND Var4<0AND Var5=0 AND Var6=0 AND Var20<(-110);
DRAWTEXT(买点1>0,L-0.15,'多'),LINETHICK2,ALIGN1,colorred;
DRAWTEXT(买点2>0,L-0.15,'多'),LINETHICK2,ALIGN1,ColorRed;
DRAWTEXT(卖点1>0,H+0.35,'空'),LINETHICK2,ALIGN1,COLOR33FF33;
 
x1:=(C+L+H)/3;
x2:=EMA(x1,6);
x3:=EMA(x2,5);
DRAWICON(CROSS(X2,X3),L-0.1,10);
DRAWICON(CROSS(X3,X2),H+0.1,12);
stickline(x2>=x3,low,high,0.1,1),colorred;
stickline(x2>=x3,close,open,9,2),colorred;
stickline(x2>=x3,close,open,9,8);
stickline(x2<x3,low,high,0.1,1),colorGREEN;
stickline(x2<x3,close,open,9,2),colorGREEN;
stickline(CROSS(X2,X3),open,close,6,1),colorYELLOW;
stickline(CROSS(X3,X2),open,close,6,1),colorBLUE;
{www.88gs.com}
a:="LTFunc6@FORLT2";
s1:="LTFunc6@LT_S1"; 
hs:="LTFunc6@LT_HS";
ls:="LTFunc6@LT_LS"; 
p1:="LTFunc6@LT_P1";
upp:="LTFunc6@LT_UPP"; 
udd:="LTFunc6@LT_UDD";
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};
买入:p1=1 and ref(p1,1)=0,LineThick0,Precis0,ColorRed;
d1:=ema(abs("SV-ddx.ddx"),60);
d2:=max("SV-ddx.ddx"/d1+7.5,7.5);
d3:=min("SV-ddx.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');
tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s1=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';
bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+'买卖点决策系统提示\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2.短线:'+tr3+tr1+'\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+tr4;
drawflagtext(1,fb,bs);{www.88gs.com}
STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
  • 本地高速下载

  • 鲜花

    握手

    雷人

    路过

    鸡蛋

    亿操盘  

    Copyright © 2001-2018 91yicaopan.   All Rights Reserved.

    Powered by 亿操盘 ( 辽ICP备15002194号-1 )

    返回顶部