亿操盘

亿操盘 首页 大智慧公式 查看内容

提供一部自用的实用的股市拼装车回报老师学长们,烦请优化成股海赛车,谢谢! - -上证 ...

2019-1-26 06:00| 发布者: yicaopan| 查看: 64| 评论: 0|原作者: [db:作者]|来自: [db:来源]

软件简介:

提供一部自用的实用的股市拼装车回报老师学长们,烦请优化成股海赛车,谢谢!


罗嗦一下:我不会写公式,也看不懂公式,所以不要问我任何问题,也不需回复,拼装的不伦不类莫见笑,会抓老鼠,实用就好,有江华老师(在我们论坛里)谢谢您,才知公式

是何物,曾经问过一品老师,让他发笑的问题,感激他不厌其烦的解释,在此谢谢,也曾让我们论坛以为我是灌水者,其实是不知游戏规则,感激给我这么多股票知识,以此回报

,谢谢大家!事先声明,如有侵犯原作者权益,请见谅,我不为名为利,我是业余的散户。
公式说明:(事后发现所有应用公式全是价与量的关系,不知是否所有公式都是价与量?)
原则:a.明天买什么股。b.什么价买。c.什么时候卖。d.什么价卖。我是从短线(3~5天)的角度来观察的。
1.导航主图,恶狼决策主图 + 三个预测股价公式 + 预测明日涨跌公式 + 一品老师,四区主图的资料说明。
  道路线:操作线,路况:红线 行,绿线 停(下车)。
  路标:见底 行,洗盘 停,“顶上图标” 停(下车),其余 仅供参考(我的观察,对不起)。
  限速线:一号支撑线,在操作线(红色)之下,是高速公路,其余情况属限速范围,下车是最好的选择(不是唯一的选择)。
  天气预报:“明日涨跌公式”,仅供参考(我的观察,对不起)。
  我习惯一个图,看见所要的资料,所以把预测股价公式及预测明日涨跌公式也摆上去。(见后面说明) 
2.发动机副图:神猴探月 + 庄家克星的抄底逃顶公式 + 庄家克星的“神奇均线” + 一品趋势跟踪公式。(也可当选股公式选股)
  a.明天买什么股,就在这里处理:
  条件:SKD差>0,山水(SS)<30,如果没有的话,逐步放宽山水值。
  选出来的股,需四个条件符合,SKD差(选的当天正好金叉),山水,为正比昨天大,神猴线(此时应该是负值)比昨天大,,倒影(最好也是负值)比昨天小。
  b.什么价买:(见后面说明)
  c.什么时候卖,那要“看图说故事”了,(对不起不会截图),线条说明:
  由上而下说明,第一条山水线(加油线),红加,黄放,变黄下车。第二条神猴线(加速线),红加速,绿减速,变绿当天或隔天就下车。第三条倒影线(刹车线),绿正常,

变黄踩刹车,下车。
  神猴线到中线的红色区(油箱),加大时,股价往上走。
  中线往上的白红三角是金叉点(高度是山水值),是启动KEY,建议您,选股时最好神猴线(大名鼎鼎的神猴探月)由绿转红,可靠又卖的时间短。
  下面的黄星点★(短穿中,金叉)上,绿圆点●(死叉)下,是“神奇均线”的A8(短线),A9(中线)。
  山水及神猴值超过65时,随时准备下车。
  山水线变黄,有时会出现黄圆点,这就是一品老师“趋势跟踪”的“挖坑”,不用介绍了,如果您心脏够强的话,建议您,“挖坑”的前面是红色区一大块时,山水神猴值在高

位60~65以上,出现“挖坑”,股价回跌不多,隔天不是大涨,就是跌。
  总结:算日子,金叉是第一天,第二天(隔天)买,第三天神猴线最好上穿中线(00)出现红色圆点(最迟第四天上午),否则卖。山水变黄,神猴变绿,倒影变黄,SKD差转负

四种情况同时出现,不用考虑就下车。如都正常时,持有,到第五天再卖。
3.预测股价副图:三个预测股价公式(“传说中预测明日股价公式”+“黄金买点”+“忘了名称,对不起原作者”)
  有三个预测值,预测一,预测二及黄金买点,当天早上9:25~9:30,才会出现预测值,不是预测明天,是今天。
  看图就会用了,有预测的差价,比例及最下面三行★代表成功,绿圆点●表示失败等的统计资料,再加上红树林园老师的闪烁图标提醒您到位了该买了。
  我的观察是,弱时用"预测一",要买时用"预测二",非买不可时"预测二*1.006",一般股价跌到"预测一"至"预测二"之间,今天股价就不会再跌了,准确率很高,黄金买点差值有

时小,有时大,有让人无所适从的感觉。
  我把预测今天最高价及收盘价()起来,因为不准,还望老师们补上。源码都在下面。
最后,希望没耽搁大家的时间,没浪费理想的版面,忘了说,我是用免费的大智慧。

所有公式源码
{导航主图  大智慧恶狼决策主图}
回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);
经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;
MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20)))  /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
MAHL2:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
MAHL3:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}

上线:=SMA(C,6.5,1);
一号支撑线:SMA(C,14.5,1);
上线1:=SMA(C,3,1);
一号支撑线1:=SMA(C,8,1);
上线2:=SMA(C,3.5,1);
DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'洗盘'),COLOR00FF00;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
UPR:=BBI+3*STD(BBI,13);
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,55);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) AND CLOSE<上线1 , HIGH*1.04,'减仓') ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:MA(A7,5),COLORRED,LINETHICK2;
操作1:=MA(A7,5)*1.03;
操作2:=MA(A7,5)*0.97;
PARTLINE(操作,操作>=REF(操作,1),RGB(255,0,0),操作<REF(操作,1),RGB(0,255,0)),Linethick2;
DRAWTEXT( CROSS(上线1,上线) AND 上线1>操作,LOW *0.95,'买进' ),COLORYELLOW;
VAR1:LLV(A7,21);
VAR2:HHV(A7,30);
DRAWTEXT( CROSS(上线1,操作) AND 上线1<一号支撑线 AND 上线1<一号支撑线1 AND 上线1<上线 AND CLOSE>VAR1,LOW *0.99,'见底' ),COLORYELLOW;
YCX:=操作>=REF(操作,1);
H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),COLORFF00FF;
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
M1:=1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975;
M2:=1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980;
M3:=1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进') ,COLORYELLOW;
D:=MA(CLOSE,89)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;
RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
K:=SMA(RSV,3,1);
D1:=SMA(K,3,1);
J:=3*K-2*D1;
VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}
E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;
F:=MA(E,3)+0.03;
G:=MA(E,1);
DRAWICON(CROSS(F,G) AND J>65,HIGH*1.02,15),COLORGREEN;
DRAWICON(CROSS(G,F),LOW *0.9,9),COLORYELLOW;
DRAWTEXT(CLOSE>OPEN AND H1<C AND O<L1 AND YCX AND CROSS(上线1,操作) AND LOW>VAR1 AND 上线1>一号支撑线 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT( CROSS(上线1,操作) AND M1 AND M2 AND M3,LOW *0.94,'买进' ),COLORYELLOW;
DRAWTEXT(CLOSE>OPEN AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CLOSE>MA(CLOSE,一号支撑线) AND 操作>=REF(CLOSE,操作) AND CROSS(上线1,操作) AND

LOW>VAR1 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT(CLOSE>OPEN AND 操作>上线 AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进'

),COLORRED;
DRAWTEXT(CLOSE>OPEN AND CROSS(上线,一号支撑线) AND LOW>VAR1 AND J<90,LOW *0.92,'回踩买进' ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;
STICKLINE(C<O AND C>REF(C,1),C,O,3,0),COLORFFCC00;
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O  ,OPEN,CLOSE,2.7,0 ),COLOR000077;{红K};
STICKLINE(CLOSE> REF(CLOSE,1) AND C>O  ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(C<REF(C,1) AND C>O,C,O,3,0),COLORFFCC00;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,3.2,0),COLORBB00FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.7,0),COLORFF33FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.1,0), COLORFF66FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,1.5,0),COLORFF99FF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;
STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;

{预测当天最低价公式}
A1:=REF(O,1);
A2:=ABS((REF(C,1)-A1)/A1);
A3:=ABS((REF(H,1)-A1)/A1);
A4:=ABS((REF(L,1)-A1)/A1);
B1:=ABS((A2+A3+A4)/3);
B2:=O*B1;
今日最高:=O+B2;
预测低一:O-B2,linethick0;
{预测当天收盘价公式}
开盘价1:=open;
开盘价2:=REF(open,1);
最高价1:=high;
最高价2:=REF(high,1);
最低价1:=low;
最低价2:=REF(low,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
AA:=最高价2;
BB:=最低价2;
CC:=开盘价2;
DD:=收盘价2;
EE:=(AA+BB+CC+2*DD)/5;
AAA:=EE+(AA-BB);
BBB:=2*EE-BB;
CCC:=2*EE-AA;
DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
FFF:=(EEE+开盘价1)/2;
GGG:=(预测低一+FFF)/2;
预测低二:GGG,colorffffff,LINETHICK0;
高:=今日最高;
收:=FFF;
DRAWTEXTABS(15,15,'★ =================='),COLORRED;
DRAWTEXTABS(15,30,'预:预测一: '+NUMTOSTRN(预测低一,2)+'元'),COLORffFFFF,linethick2;
DRAWTEXTABS(15,50,'测:最低价: '+NUMTOSTRN(low,2)+'元'),COLORyellow,linethick2;
DRAWTEXTABS(15,70,'最:预测二: '+NUMTOSTRN(预测低二,2)+'元'),COLORffFFFF,linethick2;
DRAWTEXTABS(15,90,'低:最高价: '+NUMTOSTRN(high,2)+'元'),COLOR00FFFF,linethick2;
DRAWTEXTABS(15,110,'价:收盘价: '+NUMTOSTRN(close,2)+'元'),COLOR00FFFF,linethick2;
DRAWTEXTABS(15,125,'★ =================='),COLORRED;

{一品资料说明}
WW:=BARSLAST(DISPSTATUS=1);
低涨:(C/LLV(LOW,WW)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
天:BARSLAST(L=LLV(LOW,WW)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXTABS(200,30,'■低点至今上涨:'+NUMTOSTRN(低涨,2)+'%  '+NUMTOSTRN(天,0)+'天'),COLOR0000FF;
DRAWTEXTABS(200,45,'■目前可见K线:'+NUMTOSTRN(WW+1,0)+'天'),COLORffffff;
DRAWTEXTABS(200,60,'■建议查阅K线:短线30天,中长线120天!'),COLORffffff;

DRAWTEXTABS(10,280,'★预测今日最高价: '+NUMTOSTRN(ref(今日最高,0),2)+'元'),colorffffff,linethick1;
DRAWTEXTABS(200,280,'★预测今日收盘价: '+NUMTOSTRN(ref(FFF,0),2)+'元'),colorffffff,linethick1;
DRAWTEXTABS(400,280,'★前一日预测收盘价: '+NUMTOSTRN(ref(FFF,1),2)+'元'),colorffffff,linethick1;
DRAWTEXTABS(600,280,'★前二日预测收盘价: '+NUMTOSTRN(ref(FFF,2),2)+'元'),colorffffff,linethick1;

{预测明日涨跌}
C1:=REF(CLOSE,1);
C2:=HHV(C1,2);
C3:=LLV(C1,1);
ET:=HHV(C1,2);
ET1:=REF(ET,1);
XB:=LLV(C1,1);
XB1:=REF(XB,1);
M:=BARSLAST(((CLOSE < XB) AND (C1 >= XB1)));
M11:=REF(M,1);
N9:=BARSLAST(((CLOSE > ET) AND (C1 <= ET1)));
N1:=REF(N9,1);
M21:=(BARSLAST((((M - N9) > 0) AND (M11 <= N1))) + 1);
N2:=(BARSLAST((((N9 - M) > 0) AND (N1 <= M11))) + 1);
ET2:=HHV(ET,M21);
XB2:=LLV(XB,N2);
A:=IF((((M - N9) > 0) AND (M11 <= N1)),1,IF((((N9 - M) > 0) AND (N1 <= M11)),0,2));
H1:=IF(((M - N9) > 0),CLOSE,ET2);
H2:=IF((A = 1),CLOSE,C2);
H3:=IF(((M - N9) < 0),CLOSE,XB2);
H4:=IF((A = 1),CLOSE,XB2);
H5:=IF((((M - N9) > 0) OR (A = 1)),CLOSE,H3);
H6:=REF(H5,1);
H7:=REF(H5,2);
H8:=(H5 > H6);
H9:=(((H4 = REF(H4,1)) AND (REF(H4,1) < REF(H4,2))) AND (H5 > REF(H5,2)));
H10:=(((H2 = REF(H2,1)) AND (H4 = REF(H4,1))) AND (H5 = REF(H5,2)));
W:=((H8 OR H9) OR H10);
T9:=((H5 < H6) AND (H5 < REF(H5,2)));
T10:=((H4 = REF(H4,1)) AND (H5 < REF(H5,2)));
T11:=((H3 > REF(H3,1)) AND (H5 < REF(H5,1)));
T12:=((H5 = REF(H5,1)) AND (H3 = H4));
T13:=((H2 = REF(H2,1)) AND (H2 = H5));
TW:=((((T9 OR T10) OR T11) OR T12) OR T13);
PK:=((AMOUNT * (((OPEN + CLOSE) + HIGH) + LOW)) / 4);
PK1:=IF((VOL > 0),(PK / AMOUNT),((((OPEN + CLOSE) + HIGH) + LOW) / 4));
BBP:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
DRAWTEXT(((DISPSTATUS=2 AND W) AND (BBP < 96.5)),(H5 * 1.022),' 明日 看涨'),MOVE1,colorFF00ff;
DRAWTEXT(((DISPSTATUS=2 AND TW) AND (BBP > 1)),((H5 + H4) / 2),' 明日 看跌'),MOVE0,colorffFF00;


================================================================================================

{发动机副图}

{神猴探月}
CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
YJD:=(EMA(CS,3)-50)*2;
神猴线:YJD;;
中线:=0;
PARTLINE(YJD,中线);
DRAWICON(CROSS(YJD,中线),0,8),LINETHICK2;
DRAWTEXT(cross(YJD,中线),0,'●'),COLORred,ALIGN1;
VAR7:=(1.1)*CLOSE;
VAR8:=(0.9)*CLOSE;
VAR9:=100*(WINNER(VAR7)-WINNER(VAR8));
神猴线1:=神猴线>=0;
神猴线2:=神猴线<=0;

{山水倒影  庄家克星的抄底逃顶公式}
Var1:=(2*CLOSE+HIGH+LOW)/4;
Var2:=LLV(LOW,5);
Var3:=HHV(HIGH,4);
sK:=EMA((Var1-Var2)/(Var3-Var2)*100,4);
sD:=EMA(0.667*REF(sK,1)+0.333*sK,2);
sJ:=2*sK-1*sD;
sKD差:sK-sD,colorred,LINETHICK0;
Var4:=(HHV(HIGH,4)-Var1)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
倒影: SMA(Var4,4,1),COLOR889999,LINESTICK;
Var5:=(Var1-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
Var6:=SMA(Var5,2,1);
山水: SMA(Var6,2,1),COLOR889999,LINESTICK;
金叉:if(CROSS(sK,sD)and 山水<35,山水,0),colorffffff,LINETHICK2;
金叉1:if(CROSS(sK,sD)and sK<50,20,0),colorred,LINETHICK2;
银叉:if(CROSS(sK,sD)and 山水>36,山水,0),colorffffff,LINETHICK2;
VERTLINE(CROSS(金叉,0.1),2),COLORffffff;
{DRAWICON(金叉,山水,10),LINETHICK6;}
{FILLRGN(0,山水,RGB(250,250,0)),COLORblue,LAYER7;}
FILLRGN(0,神猴线,神猴线1,RGB(255,48,48)),LAYER7;
{FILLRGN(0,神猴线,神猴线2,RGB(50,25,0)),LAYER7;}
{FILLRGN(0,倒影,RGB(250,250,0)),COLORgreen,LAYER7;}
PARTLINE(山水,山水>REF(山水,1),RGB(255,0,0),山水<REF(山水,1),RGB(250,250,0)),linethick2;
PARTLINE(倒影,倒影<REF(倒影,1),RGB(0,255,0),倒影>REF(倒影,1),RGB(250,250,0)),linethick2;
PARTLINE(神猴线,神猴线>REF(神猴线,1),RGB(255,0,0),神猴线<REF(神猴线,1),RGB(0,250,0)),linethick2;
VERTLINE(CROSS(神猴线1,0.1),2),COLOR0000FF;
顶线:80,COLORred;
强势:65,COLORffffff,dotline,precis2;
{金顶:50,COLORffffff,dotline,precis2;}
{金差:35,COLORred,dotline,precis2;}
{金底:20,COLORffffff,dotline,precis2;}
中线:0,COLORffffff,dotline,precis2;
转势:-65,COLORred,dotline,precis2;
底线:-80,COLORgreen;

DRAWTEXT(DISPSTATUS=2,顶线,'  80  顶线'),COLORred,ALIGN0;
DRAWTEXT(DISPSTATUS=2,强势,'  65  强势'),COLORffffff,ALIGN0;
{DRAWTEXT(DISPSTATUS=2,金顶,'  50  金顶'),COLORffffff,ALIGN0;}
{DRAWTEXT(DISPSTATUS=2,金差,'  35  金差'),COLORred,ALIGN0;}
{DRAWTEXT(DISPSTATUS=2,金底,'  20  金底'),COLORffffff,ALIGN0;}
DRAWTEXT(DISPSTATUS=2,中线,'  00  中线'),COLOR00FFFF,ALIGN0;
DRAWTEXT(DISPSTATUS=2,转势,' -65  转势'),COLORred,ALIGN0;
DRAWTEXT(DISPSTATUS=2,底线,' -80  底线'),COLORgreen,ALIGN0;

短线:=("神奇均线.A8");
中线:=("神奇均线.A9");
DRAWTEXT(cross(短线,中线),-65,'☆'),COLORyellow,ALIGN1;
DRAWTEXT(cross(中线,短线),-65,'●'),COLORgreen,ALIGN1;

{一品趋势跟踪公式}
挖坑:="趋势跟踪.挖坑";
趋势:="趋势跟踪.趋势";
{FILLRGN(50,趋势,挖坑,RGB(250,250,0)),LAYER7;}
DRAWTEXT(挖坑,山水,'●'),COLORyellow,ALIGN1;

========================================================================
{预测股价公式}
{预测当天最低价公式}
A1:=REF(O,1);
A2:=ABS((REF(C,1)-A1)/A1);
A3:=ABS((REF(H,1)-A1)/A1);
A4:=ABS((REF(L,1)-A1)/A1);
B1:=ABS((A2+A3+A4)/3);
B2:=O*B1;
今日最高:=O+B2;
预测低一:O-B2,linethick0;
最低价:low,coloryellow,linethick0;

{预测当天股价公式}
开盘价1:=open;
开盘价2:=REF(open,1);
最高价1:=high;
最高价2:=REF(high,1);
最低价1:=low;
最低价2:=REF(low,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
AA:=最高价2;
BB:=最低价2;
CC:=开盘价2;
DD:=收盘价2;
EE:=(AA+BB+CC+2*DD)/5;
AAA:=EE+(AA-BB);
BBB:=2*EE-BB;
CCC:=2*EE-AA;
DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
FFF:=(EEE+开盘价1)/2;
GGG:=(预测低一+FFF)/2;
预测低二:GGG,colorffffff,LINETHICK0;

{黄金买点公式}
hjmd:("黄金买点.hjmd"),colorffffff,LINETHICK0;

最新价:close,coloryellow,linethick0;
最高价:high,colorred,linethick0;
开盘价:open,colorffffff,linethick0;
高:=今日最高;
收:=FFF;
差额一:预测低一-low,colorffffff,LINETHICK0;
差额二:预测低二-low,colorffffff,LINETHICK0;
差额三:hjmd-low,colorffffff,LINETHICK0;
差比一:(差额一/low)*100,colorffffff,LINETHICK0;
差比二:(差额二/low)*100,colorffffff,LINETHICK0;
差比三:(差额三/low)*100,colorffffff,LINETHICK0;
DRAWTEXTREL(10,100,'★今日最低价:'+NUMTOSTRN(low,2)+'元'),coloryellow,linethick1;
DRAWTEXTREL(180,100,'★预测今日最低价: 预测一: '+NUMTOSTRN(ref(预测低一,0),2)+'元'+'    预测二: '+NUMTOSTRN(ref(ggg,0),2)+'元'+'    黄金买点: '+NUMTOSTRN

(ref(hjmd,0),2)+'元'),colorffffff,linethick1;
DRAWTEXTREL(180,250,'★  目前差价  ★  对照值: '+NUMTOSTRN(ref(差额一,0),2)+'元'+'    对照值: '+NUMTOSTRN(ref(差额二,0),2)+'元'+'      对照值: '+NUMTOSTRN

(ref(差额三,0),2)+'元'),coloryellow,linethick1;
DRAWTEXTREL(180,400,'★  目前差比  ★  对照值: '+NUMTOSTRN(ref(差比一,0),2)+'%'+'     对照值: '+NUMTOSTRN(ref(差比二,0),2)+'%'+'       对照值: '+NUMTOSTRN

(ref(差比三,0),2)+'%'),coloryellow,linethick1;
顶线:80,COLORred;
黄金点:=-20;
预测一:=-35;
预测二:=-50;
失败:=-65;
底线:=-75;
DRAWTEXT(DISPSTATUS=2,顶线,'  80  顶线'),COLORred,ALIGN0;
DRAWTEXT(DISPSTATUS=2,黄金点,'  黄金买点'),COLORffffff,ALIGN0;
DRAWTEXT(DISPSTATUS=2,预测一,'    预测一'),COLORred,ALIGN0;
DRAWTEXT(DISPSTATUS=2,预测二,'    预测二'),COLORyellow,ALIGN0;
DRAWTEXT(DISPSTATUS=2,失败,'    未到位'),COLORgreen,ALIGN0;
DRAWTEXT(DISPSTATUS=2,底线,'  -75 底线'),COLORgreen,ALIGN0;
DRAWTEXT(low<hjmd,-20,'☆'),COLORffffff,ALIGN1;
DRAWTEXT(low>hjmd,-20,'●'),COLORgreen,ALIGN1;
DRAWTEXT(low<预测低一,-35,'☆'),COLORred,ALIGN1;
DRAWTEXT(low<预测低二,-50,'☆'),COLORyellow,ALIGN1;
DRAWTEXT(low>预测低二,-65,'●'),COLORgreen,ALIGN1;

{说明:红树林园 这一段源码做出来的效果是买点到位闪烁交替显示[风险]和[注意]};
Amod:=MOD(CURRENTTIME,2);
Amod:=MOD(CURRENTTIME,2);

DRAWTEXT(DISPSTATUS=2 and low<预测低一 and Amod=0,60,'预测一 ☆'),colorred;
DRAWTEXT(DISPSTATUS=2 and low<预测低一 and Amod=1,60,'预测一 ☆'),coloryellow;
DRAWTEXT(DISPSTATUS=2 and low<预测低二 and Amod=0,40,'预测二 ☆'),colorred;
DRAWTEXT(DISPSTATUS=2 and low<预测低二 and Amod=1,40,'预测二 ☆'),coloryellow;
DRAWTEXT(DISPSTATUS=2 and low<hjmd and Amod=0,20,'黄金买点 ☆'),colorred;
DRAWTEXT(DISPSTATUS=2 and low<hjmd and Amod=1,20,'黄金买点 ☆'),coloryellow;

DRAWTEXT(DISPSTATUS=2 and low>预测低一 and Amod=0,60,'预测一 ●'),colorgreen;
DRAWTEXT(DISPSTATUS=2 and low>预测低一 and Amod=1,60,'预测一 ●'),colorffffff;
DRAWTEXT(DISPSTATUS=2 and low>预测低二 and Amod=0,40,'预测二 ●'),colorgreen;
DRAWTEXT(DISPSTATUS=2 and low>预测低二 and Amod=1,40,'预测二 ●'),colorffffff;
DRAWTEXT(DISPSTATUS=2 and low>hjmd and Amod=0,20,'黄金买点 ●'),colorgreen;
DRAWTEXT(DISPSTATUS=2 and low>hjmd and Amod=1,20,'黄金买点 ●'),colorffffff;
===========================================================================

{神奇均线}

{庄家克星  神奇均线主图}
Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1: (EMA(Var1,3)+EMA(Var1,6)+EMA(Var1,12)+EMA(Var1,24))/4;
A2: EMA(A1,2);
A3: EMA(A2,2);
A4: EMA(A3,2);
A5: EMA(A4,2);
A6: EMA(A5,2);
A7: EMA(A6,2);
A8: EMA(Var1,2.78)*1.028,colorffffff,linethick1;
A9: MA(OPEN,3.2)*1.028,colorgreen,linethick1;

PARTLINE(A1,A1>REF(A1,1),RGB(255,0,0),A1<REF(A1,1),RGB(250,250,0)),linethick2;
PARTLINE(A8,A9);
DRAWTEXT(CROSS(A8,A9),A8,'★'),COLORyellow,LINETHICK1;
DRAWTEXT(CROSS(A9,A8),A9,'●'),COLORgreen,LINETHICK1;
DRAWTEXTREL(10,100,'== ★点 '),coloryellow,linethick1;
DRAWTEXTREL(50,100,'  红线 股价上升 =='),colorred,linethick1;
DRAWTEXTREL(10,250,'= ●点 '),colorgreen,linethick1;
DRAWTEXTREL(50,250,'  黄线 股价下降 = '),coloryellow,linethick1;

安全线: EMA(CLOSE,55),colorgreen, CIRCLEDOT;

=========================================================================================

{趋势跟踪}

{趋势跟踪----创幻论坛一品茶缘编写,大智慧L2版本副图指标}
{【趋势跟踪】指标使用说明:
趋势为王守铁律,顺势而为主升期;
临界出现防风险,挖坑不涨早休息!}

MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:(A1+A2+A3+A4+A5+A6)/6*100,Color00FF00;
主升浪:趋势>=50,COLOR0000FF,POINTDOT,LINETHICK0;
↓:趋势<50,COLORFFFFFF,POINTDOT,LINETHICK0;
周期:IF(主升浪,BARSLAST(CROSS(主升浪,0.1))+1,0),COLORFF00FF,POINTDOT,LINETHICK0;
临界:IF(CROSS(98,趋势),1,0),COLOR00FF00,POINTDOT,LINETHICK0;
WKQY:=BARSLAST(CROSS(50,趋势))<MIN(BARSLAST(CROSS(趋势,1)),BARSLAST(CROSS(趋势,-1)));
挖坑:BETWEEN(趋势,-1,50) and WKQY,COLOR00FFFF,POINTDOT,LINETHICK0;
{以下设置副图显示方式}
FILLRGN(50,趋势,主升浪,RGB(250,0,0)),LAYER7;
FILLRGN(50,趋势,挖坑,RGB(250,250,0)),LAYER7;
STICKLINE(主升浪,周期*0.8,周期*0.95,6,0),COLOR0000FF;
STICKLINE(主升浪,周期*1.05,周期*1.2,6,0),COLOR0000FF;
STICKLINE(主升浪 AND C<REF(C,1),周期*0.9,周期*1.1,6,1),COLORFFFFFF;
VERTLINE(CROSS(主升浪,0.1),2),COLOR0000FF;
DRAWTEXT(临界,100,'☆'),COLOR00FF00,ALIGN1;
0,COLORFFFFFF;50,COLOR00FFFF,DOTLINE;
{以下设置文字提示部分}
DRAWTEXTREL(10,620,'股票名称:'+'【'+STKLABEL+' '+STKNAME+'】'),COLORFFFFFF;
DRAWTEXTREL(10,800,'== ● 趋势为王.顺势而为 ●  =='),COLOR0000FF;
DRAWTEXTREL(200,800,' == ■ 只做主升,挖坑低吸 ■ =='),COLOR00FFFF;
DRAWTEXTREL(400,800,' == ☆ 临界不涨,逢高离场 ☆ =='),COLORgreen;

=============================================================================================
{黄金买点}
zz:=(o+h+l)/3;   
hjmd:EMA(zz,4),COLORYELLOW,LINETHICK1;   
xxb:=CLOSE*VOL;   
xxbym:EMA((EMA(xxb,3)/EMA(VOL,3)+EMA(xxb,6)/EMA(VOL,6)+EMA(xxb,12)/EMA(VOL,12)+EMA(xxb,24)/EMA(VOL,24))/4,13),colorff00ff,LINETHICK0;   
  
爱心:=EMA(CLOSE,13)-EMA(CLOSE,55);   
无价:=EMA(爱心,3);   
PARTLINE(xxbym,爱心>=无价,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK2;   
DRAWTEXTREL(700,120,'今日买点:'+NUMTOSTRN(hjmd,2 )),LINETHICK2,coloryellow;   
  
yc:=(h+l)/2;   
ychjx:=(EMA(zz,4))+(yc-ref(zz,3))/4;   
DRAWTEXTREL(650,20,'昨测今日买点:'+NUMTOSTRN(ref(ychjx,1),2)),LINETHICK2,colorFF00FF;   
DRAWTEXTREL(700,220,'明日买点:'+NUMTOSTRN(ychjx,2)),LINETHICK2,colorff00ff;

==============================================================================================


其中一小段,飞狐的:
{发动机副图}

{神猴探月}
CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
YJD:=(EMA(CS,3)-50)*2;
神猴线:YJD;;
中线:=0;
PARTLINE(YJD,中线);
DRAWICON(CROSS(YJD,中线),0,8),LINETHICK2;
DRAWTEXT(cross(YJD,中线),0,'●'),COLORred,ALIGN1;
VAR7:=(1.1)*CLOSE;
VAR8:=(0.9)*CLOSE;
VAR9:=100*(WINNER(VAR7)-WINNER(VAR8));
神猴线1:=神猴线>=0;
神猴线2:=神猴线<=0;

{山水倒影  庄家克星的抄底逃顶公式}
Var1:=(2*CLOSE+HIGH+LOW)/4;
Var2:=LLV(LOW,5);
Var3:=HHV(HIGH,4);
sK:=EMA((Var1-Var2)/(Var3-Var2)*100,4);
sD:=EMA(0.667*REF(sK,1)+0.333*sK,2);
sJ:=2*sK-1*sD;
sKD差:sK-sD,colorred,LINETHICK0;
Var4:=(HHV(HIGH,4)-Var1)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
倒影: SMA(Var4,4,1),COLOR889999,LINESTICK;
Var5:=(Var1-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
Var6:=SMA(Var5,2,1);
山水: SMA(Var6,2,1),COLOR889999,LINESTICK;
金叉:if(CROSS(sK,sD)and 山水<35,山水,0),colorffffff,LINETHICK2;
金叉1:if(CROSS(sK,sD)and sK<50,20,0),colorred,LINETHICK2;
银叉:if(CROSS(sK,sD)and 山水>36,山水,0),colorffffff,LINETHICK2;
VERTLINE(CROSS(金叉,0.1)),COLORffffff;
DRAWTEXT(金叉,-70,'金叉'),colorred;

FILLRGN(神猴线>=0,0,神猴线);
FILLRGN(神猴线<0,0,神猴线);

PARTLINE(山水>REF(山水,1),山水),linethick2;
PARTLINE(山水<REF(山水,1),山水),linethick2;

PARTLINE(倒影<REF(倒影,1),倒影),linethick2;
PARTLINE(倒影<REF(倒影,1),倒影),linethick2;
PARTLINE(神猴线>REF(神猴线,1),神猴线),linethick2;
PARTLINE(神猴线<REF(神猴线,1),神猴线),linethick2;
顶线:80,COLORred;
强势:65,COLORffffff;
转势:-65,COLORred;
底线:-80,COLORgreen;


把6个主副图公式分别新建在您的软件上,就可以使用了,我炒股主要就用这些,建议各位学长,不要小看“股价预测公式”,在盘中最低价没跌到预测二附近或者预测一级预测二之间,尽管是在涨的过程,还是会回跌的,除非非常强势的个股,那预测就不准了,对股票,我的看法是只要您能在接近最低价买到任何一只股票,已经保证不赔了,如果今天最低价高于明天的股价,那股市没得玩的,惨绿绿一片,您说是不?













公式下载请打开:整理整合蔡佑佑先生的全套实战公式指标-实战指标
http://www.88gs.comhttp://www.88gs.com/soft/sort013/sort03/down-20676.html

参考:
提供一部自用的实用的股市拼装车回报老师学长们,烦请优化成股海赛车,谢谢!
与其等三天五个百分比,不如天天要个1.5%,有买入价,卖出价的公式!
一天十分钟!让您把手中的鸡肋当鸡腿天天吃!不需丰富实战经验的 T+0 自动化的玩法!

整理整合蔡佑佑先生的全套实战公式指标-实战指标

【恶狼决策】主图、增加配套全仓选股

  • 下载地址1

  • 鲜花

    握手

    雷人

    路过

    鸡蛋
    超低手续费扫码注册上证50ETF期权

    亿操盘  

    Copyright © 2001-2018 91yicaopan.   All Rights Reserved.

    Powered by 亿操盘 ( 辽ICP备15002194号-1 ) 联系电话: 4001825055

    返回顶部

    点击这里给我发消息

    客户服务热线

    400-182-5055

    在线客服